]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/phalanx/phalanx_22.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / phalanx / phalanx_22.bb
1 DESCRIPTION = "Phalanx is a chess playing engine."
2 SECTION = "opie/libs"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer"
5 PR = "r3"
6 LICENSE = "GPL"
7 SRC_URI = "http://dusan.freeshell.org/phalanx/phalanx-${PV}.tar.gz \
8            file://gcc3.patch;patch=1 \
9            file://capabilities \
10            file://description"
11 S = "${WORKDIR}/Phalanx-XXII"
12
13 do_compile() {
14         oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
15 }
16
17 do_install() {
18         install -d ${D}${palmtopdir}/chess/engines/Phalanx
19         install -D -m 755 phalanx ${D}${palmtopdir}/chess/engines/Phalanx/phalanx
20         install -D -m 755 pbook.phalanx ${D}${palmtopdir}/chess/engines/Phalanx/pbook.phalanx
21         >${D}${palmtopdir}/chess/engines/Phalanx/sbook.phalanx
22         >${D}${palmtopdir}/chess/engines/Phalanx/learn.phalanx
23         install -D -m 755 ${WORKDIR}/capabilities ${D}${palmtopdir}/chess/engines/Phalanx/capabilities
24         install -D -m 755 ${WORKDIR}/description ${D}${palmtopdir}/chess/engines/Phalanx/description
25 }
26
27 FILES_${PN} = "${palmtopdir}/chess"