]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/pocketcellar/pocketcellar_1.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / pocketcellar / pocketcellar_1.1.bb
1 DESCRIPTION = "Wine cellar manager. Allows you to record details of wines and \
2 those you have in your cellar. The Food Assistant will make suggestions of wines \
3 suitable for your meal, and indicate those in your cellar that match."
4 SECTION = "opie/applications"
5 PRIORITY = "optional"
6 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
7 LICENSE = "GPL"
8 PR = "r3"
9
10 SRC_URI = "http://www.staikos.net/~staikos/pocketcellar/pocketcellar-${PV}.tar.gz \
11            file://winedb.patch;patch=1 \
12            file://cellardb.patch;patch=1 \
13            file://pocketcellar.patch;patch=1 \
14            file://gcc3.patch;patch=1"
15
16 inherit palmtop
17
18 EXTRA_QMAKEVARS_POST = " DESTDIR=pkg-cellar/home/QtPalmtop/bin/"
19
20 do_install() {
21         install -d ${D}${palmtopdir}/bin \
22                    ${D}${palmtopdir}/apps/Applications \
23                    ${D}${palmtopdir}/pics \
24                    ${D}${palmtopdir}/data/PocketCellar
25                            
26         install -m 644 pkg-pcellar/home/QtPalmtop/data/PocketCellar/* ${D}${palmtopdir}/data/PocketCellar/
27         install -m 755 pkg-cellar/home/QtPalmtop/bin/pocketcellar ${D}${palmtopdir}/bin/
28         install -m 644 pocketcellar.desktop ${D}${palmtopdir}/apps/Applications/
29         install -m 644 pocketcellar.png ${D}${palmtopdir}/pics/
30         install -m 644 pkg-pcellar/home/root/Settings/foodassist.conf ${D}${palmtopdir}/data/PocketCellar/
31 }
32
33 FILES_${PN} = "/"