]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/portabase/beecrypt_3.1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / portabase / beecrypt_3.1.0.bb
1 SECTION = "console/utils"
2 DESCRIPTION = "BeeCrypt is an ongoing project to provide a strong and fast cryptography \
3 toolkit. Includes entropy sources, random generators, block ciphers, hash functions, \
4 message authentication codes, multiprecision integer routines, and public key primitives."
5
6 HOMEPAGE = "http://sourceforge.net/projects/beecrypt/"
7 LICENSE = "LGPL"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
9 file://config.m4 \
10 file://gas.patch;patch=1 \
11 file://m4.diff;patch=1"
12 PR = "r1"
13
14 inherit autotools
15
16 do_configure_prepend() {
17
18 cp ${WORKDIR}/config.m4 ${S}/gas/
19
20 }
21
22
23 do_stage() {
24         
25 #       oe_libinstall  -a  -C .libs libbeecrypt  ${STAGING_LIBDIR}
26         cp .libs/libbeecrypt.a ${STAGING_LIBDIR}/
27         install -d ${STAGING_INCDIR}/
28         install -d ${STAGING_INCDIR}/beecrypt
29         for X in beecrypt.h beecrypt.api.h memchunk.h mpnumber.h beecrypt.gnu.h mp.h mpopt.h blockmode.h endianness.h
30         do
31                 install -m 0644 ${X} ${STAGING_INCDIR}/beecrypt/${X}
32         done
33
34 }