]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/portabase/metakit_2.4.9.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / portabase / metakit_2.4.9.3.bb
1 SECTION = "libs"
2 DESCRIPTION = "Metakit is an efficient embedded database library with a small \
3 footprint. It fills the gap between flat-file, relational, object-oriented, and \
4 tree-structured databases, supporting relational joins, serialization, nested structures,\
5 and instant schema evolution."
6 LICENSE = "MetaKit"
7 HOMEPAGE = "http://www.equi4.com/metakit.html"
8
9 SRC_URI = "http://www.equi4.com/pub/mk/older/metakit-${PV}.tar.gz \
10            file://metakit-2.4.9.3.patch;patch=1"
11 PR = "r1"
12
13 do_configure_prepend() {
14
15         cp ${STAGING_DATADIR}/libtool/* ${S}/unix/scripts/
16         
17 }
18 do_configure () {
19
20         cd builds
21         ../unix/configure \
22                    --build=${BUILD_SYS} \
23                     --host=${HOST_SYS} \
24                     --target=${TARGET_SYS} \
25                     --prefix=${prefix} \
26                     --exec_prefix=${exec_prefix} \
27                     --bindir=${bindir} \
28                     --sbindir=${sbindir} \
29                     --libexecdir=${libexecdir} \
30                     --datadir=${datadir} \
31                     --sysconfdir=${sysconfdir} \
32                     --sharedstatedir=${sharedstatedir} \
33                     --localstatedir=${localstatedir} \
34                     --libdir=${libdir} \
35                     --includedir=${includedir} \
36                     --oldincludedir=${oldincludedir} \
37                     --infodir=${infodir} \
38                     --mandir=${mandir} \
39                         ${EXTRA_OECONF} \
40                     $@;
41         
42 }
43
44
45 do_stage() {
46 #       oe_libinstall  -a  -C builds/.libs libmk4  ${STAGING_LIBDIR}
47         cp builds/.libs/libmk4.a ${STAGING_LIBDIR}
48         install -d ${STAGING_INCDIR}/
49         for X in mk4.h mk4.inl
50         do
51                 install -m 0644 include/${X} ${STAGING_INCDIR}/${X}
52         done
53
54 }
55
56
57
58 do_compile () {
59         cd builds       
60         oe_runmake
61 }
62
63 do_install() {
64         
65         :
66 }