]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/prelink/prelink_20031029.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / prelink / prelink_20031029.bb
1 SECTION = "devel"
2 DEPENDS = "elfutils "
3 DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
4 and executables, so that far fewer relocations need to be resolved at \
5 runtime and thus programs come up faster."
6 LICENSE = "GPL"
7 SRC_URI = "ftp://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
8            file://dso.c.patch;patch=1 \
9            file://layout.c.patch;patch=1 \
10            file://Makefile.in.patch;patch=1 \
11            file://prelink.h.patch;patch=1 \
12            file://ts.Makefile.am.patch;patch=1 \
13            file://ts.Makefile.in.patch;patch=1 \
14            file://prelink.conf \
15            file://prelink.cron.daily \
16            file://prelink.default"
17 S = "${WORKDIR}/prelink"
18
19 inherit autotools 
20
21 do_install_append () {
22         install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
23         install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
24         install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
25         install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
26 }