]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/procps/procps_3.2.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / procps / procps_3.2.5.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Procps is the package that has a bunch \
3 of small useful utilities that give information \
4 about processes using the /proc filesystem. The package \
5 includes the programs ps, top, vmstat, w, kill, and skill."
6 SECTION = "base"
7 PRIORITY = "optional"
8 MAINTAINER = "Inge Arnesen <inge.arnesen@gmail.com>"
9 DEPENDS = "ncurses"
10 PR = "r4"
11
12 SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
13            file://install.patch;patch=1 \
14            file://procmodule.patch;patch=1 \
15            file://psmodule.patch;patch=1"
16
17
18
19 inherit autotools 
20 FILES = "${bindir}/top.${PN} ${base_bindir}/ps.${PN} ${bindir}/uptime.${PN} ${base_bindir}/kill.${PN} \
21          ${bindir}/free.${PN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \
22          ${bindir}/snice ${bindir}/vmstat ${bindir}/slabtop ${bindir}/pkill ${bindir}/skill ${bindir}/tload \
23          ${base_sbindir}/sysctl"
24
25 EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
26                 CPPFLAGS=-I${STAGING_INCDIR} \
27                 LDFLAGS=-L${STAGING_LIBDIR} -Wl,--rpath-link,${STAGING_LIBDIR} \
28                 CURSES=-lncurses \
29                 install='install -D' \
30                 ldconfig=echo"
31
32 do_install_append () {
33         mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
34         mv ${D}${bindir}/top ${D}${bindir}/top.${PN}
35         mv ${D}${base_bindir}/kill ${D}${base_bindir}/kill.${PN}
36         mv ${D}${base_bindir}/ps ${D}${base_bindir}/ps.${PN}
37         mv ${D}${bindir}/free ${D}${bindir}/free.${PN}
38 }       
39
40 pkg_postinst() {
41         update-alternatives --install ${bindir}/top top top.${PN} 90
42         update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 90
43         update-alternatives --install ${base_bindir}/ps ps ps.${PN} 90
44         update-alternatives --install ${base_bindir}/kill kill kill.${PN} 90
45         update-alternatives --install ${bindir}/free free free.${PN} 90
46 }
47
48 pkg_postrm() {
49         update-alternatives --remove top top.${PN}
50         update-alternatives --remove ps ps.${PN}
51         update-alternatives --remove uptime uptime.${PN}
52         update-alternatives --remove kill kill.${PN}
53         update-alternatives --remove free free.${PN}
54 }