]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-dbus_0.23.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-dbus_0.23.bb
1 DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
2 SECTION = "devel/python"
3 HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
7 RDEPENDS = "dbus"
8 PR = "ml1"
9
10 SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
11            file://cross.patch;patch=1 \
12            file://tmpdir.patch;patch=1 \
13            file://gettext.patch;patch=1"
14 S = "${WORKDIR}/dbus-${PV}"
15
16 inherit autotools pkgconfig gettext
17
18 EXTRA_OECONF = "--disable-qt --disable-gtk --disable-tests \
19                 --disable-checks --disable-xml-docs --disable-doxygen-docs \
20                 --with-xml=expat --without-x --enable-python"
21
22 FILES_${PN} = "${libdir}/python2.4/site-packages/dbus.* ${libdir}/python2.4/site-packages/dbus_bindings.so"
23