]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-libgmail_0.1.3.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-libgmail_0.1.3.3.bb
1 DESCRIPTION = "Python Bindings for Google's Gmail Service"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 RDEPENDS = "python-core python-netclient python-email python-mime python-pprint python-re python-pickle"
7 SRCNAME = "libgmail"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10 S = "${WORKDIR}/${SRCNAME}-${PV}"
11
12 inherit distutils-base
13
14 do_install() {
15         install -d ${D}${libdir}/${PYTHON_DIR}
16         for file in *.py
17         do
18                 install -m 0755 ${file} ${D}${libdir}/${PYTHON_DIR}
19         done
20 }