]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-native_2.3.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-native_2.3.3.bb
1 DESCRIPTION = "Python Programming Language"
2 HOMEPAGE = "http://www.python.org"
3 LICENSE = "PSF"
4 SECTION = "devel/python"
5 PRIORITY = "optional"
6 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
7 DEPENDS = ""
8 PR = "r1"
9
10 SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
11            file://bindir-libdir.patch;patch=1             \
12            file://cross-distutils.patch;patch=1"
13 S = "${WORKDIR}/Python-${PV}"
14
15 inherit autotools native
16
17 EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc --without-cxx --with-signal-module --with-wctype-functions \
18                 --with-prefix=${STAGING_DIR} --with-exec-prefix=${STAGING_DIR}/${BUILD_SYS}"
19 EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
20
21 do_configure () {
22         oe_runconf
23 }
24
25 do_stage_append() {
26         # install pgen for later usage with non-native builds
27         install Parser/pgen ${STAGING_DIR}/${BUILD_SYS}/bin/
28 }
29