]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-native_2.4.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-native_2.4.0.bb
1 DESCRIPTION = "Python Programming Language"
2 HOMEPAGE = "http://www.python.org"
3 LICENSE = "PSF"
4 SECTION = "devel/python"
5 PRIORITY = "optional"
6 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
7 DEPENDS = ""
8 PR = "r0"
9
10 EXCLUDE_FROM_WORLD = "1"
11
12 SRC_URI = "http://www.python.org/ftp/python/2.4/Python-2.4.tar.bz2 \
13            file://bindir-libdir.patch;patch=1             \
14            file://cross-distutils.patch;patch=1"
15 S = "${WORKDIR}/Python-2.4"
16
17 inherit autotools native
18
19 EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc --without-cxx --with-signal-module --with-wctype-functions \
20                 --with-prefix=${STAGING_DIR} --with-exec-prefix=${STAGING_DIR}/${BUILD_SYS}"
21 EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
22
23 do_configure () {
24         oe_runconf
25 }
26
27 do_stage_append() {
28         # install pgen for later usage with non-native builds
29         install Parser/pgen ${STAGING_DIR}/${BUILD_SYS}/bin/
30 }
31