]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-pygame_1.7.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-pygame_1.7.1.bb
1 DESCRIPTION = "Python libSDL Bindings"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "LGPL"
6 RDEPENDS = "python-core python-numeric libsdl-x11"
7 DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
8 SRCNAME = "pygame"
9 PR = "ml1"
10
11 SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}release.tar.gz \
12            file://Setup"
13 S = "${WORKDIR}/${SRCNAME}-${PV}release"
14
15 inherit distutils
16
17 do_configure_prepend() {
18         SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >Setup
19         cat ${WORKDIR}/Setup >>Setup
20 }