]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-pygtk-0_0.6.12.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-pygtk-0_0.6.12.bb
1 LICENSE = "LGPL"
2 DESCRIPTION = "Python GTK+ 1.2 Bindings"
3 SECTION = "devel/python"
4 PRIORITY = "optional"
5 MAINTAINER = "Rob Taylor <robtaylor@fastmail.fm>"
6 DEPENDS = "gtk+-1.2 python"
7 RDEPENDS = "python-core python-shell python-re"
8 SRCNAME = "pygtk"
9 PR = "r4"
10
11 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/python-pygtk-${PV}"
12
13
14 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/python/v1.2/${SRCNAME}-${PV}.tar.gz \
15            file://remove-imlib-et-al;patch=1"
16 S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18 inherit autotools pkgconfig distutils-base
19
20 FILES_${PN} = "${libdir}/${PYTHON_DIR}/"
21
22 do_configure_prepend() {
23         echo ${LDFLAGS} > /tmp/ldflags
24         rm -f aclocal.m4
25 }
26
27 do_stage() {
28         autotools_stage_includes
29 }
30