]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-scapy_0.9.17.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-scapy_0.9.17.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Scapy is a powerful interactive packet manipulation tool, \
3 packet generator, network scanner, network discovery, packet sniffer, etc. \
4 It can for the moment replace hping, 85% of nmap, arpspoof, arp-sk, arping, \
5 tcpdump, tethereal, p0f, ...."
6 SECTION = "devel/python"
7 PRIORITY = "optional"
8 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
9 RDEPENDS = "python-core python-netclient python-netserver"
10 SRCNAME = "scapy"
11
12 SRC_URI = "http://www.secdev.org/projects/scapy/files/scapy-${PV}.tar.gz"
13 S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15 do_install() {
16         install -d ${D}${libdir}/${PYTHON_DIR}
17         install -m 0755 ${S}/scapy.py ${D}${libdir}/${PYTHON_DIR}/
18 }
19
20 FILES_${PN} = "${libdir}/${PYTHON_DIR}/"
21