]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-sword_1.5.8.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-sword_1.5.8.bb
1 DESCRIPTION = "Python bindings for the sword library"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 MAINTAINER = "Matt Reimer <mreimer@vpop.net>"
5 LICENSE = "GPL"
6 RDEPENDS = "python-core sword"
7 DEPENDS = "sword-${PV} swig-native"
8 SRCNAME = "sword"
9 PR = "r0"
10
11 SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
12 S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
13
14 EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
15
16 inherit distutils autotools
17
18 PARALLEL_MAKE = ""
19
20 do_configure_prepend() {
21         ./autogen.sh
22 }
23
24 do_compile() {
25         oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
26 }
27
28 do_install() {
29         cd ${S}/python
30         distutils_do_install
31 }