]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python-vorbis_1.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python-vorbis_1.3.bb
1 DESCRIPTION = "Python Vorbis Bindings"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "LGPL"
6 RDEPENDS = "python-core libvorbis python-ogg"
7 DEPENDS = "libvorbis python-ogg"
8 SRCNAME = "pyvorbis"
9
10 SRC_URI = "http://www.andrewchatham.com/pyogg/download/${SRCNAME}-${PV}.tar.gz \
11            file://disable-oggcheck.patch;patch=1"
12 S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14 inherit distutils
15
16 do_configure_prepend() {
17         touch Setup
18         echo "ogg_libs = ogg" >>Setup
19         echo "ogg_lib_dir = ${STAGING_LIBDIR}" >>Setup
20         echo "ogg_include_dir = ${STAGING_INCDIR}" >>Setup
21         echo "vorbis_libs = vorbis vorbisfile vorbisenc" >>Setup
22         echo "vorbis_lib_dir = ${STAGING_LIBDIR}" >>Setup
23         echo "vorbis_include_dir = ${STAGING_INCDIR}" >>Setup
24 }