]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/python/python_2.3.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / python / python_2.3.4.bb
1 DESCRIPTION = "Python Programming Language"
2 HOMEPAGE = "http://www.python.org"
3 LICENSE = "PSF"
4 SECTION = "devel/python"
5 PRIORITY = "optional"
6 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
7 DEPENDS = "python-native zlib gdbm"
8 PR = "ml4"
9
10 SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
11            file://bindir-libdir.patch;patch=1 \
12            file://crosscompile.patch;patch=1"
13 S = "${WORKDIR}/Python-${PV}"
14
15 inherit autotools
16
17 EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc --without-cxx --with-signal-module --with-wctype-functions"
18
19 #
20 # copy config.h and an appropriate Makefile for distutils.sysconfig
21 # which laters uses the information out of these to compile extensions
22 #
23 do_compile_prepend() {
24         install -d ${STAGING_INCDIR}/python2.3/
25         install -d ${STAGING_LIBDIR}/python2.3/config/
26         install -m 0644 pyconfig.h ${STAGING_INCDIR}/python2.3/
27         install -m 0644 Makefile Makefile.orig
28         install -m 0644 Makefile Makefile.backup
29         sed -e 's,${includedir},${STAGING_INCDIR},' < Makefile.backup > Makefile
30         install -m 0644 Makefile Makefile.backup
31         sed -e 's,${libdir},${STAGING_LIBDIR},' < Makefile.backup > Makefile
32         install -m 0644 Makefile ${STAGING_LIBDIR}/python2.3/config/
33 }
34
35 do_compile() {
36         oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
37                    HOSTPYTHON=${STAGING_BINDIR}/python \
38                    STAGING_LIBDIR=${STAGING_LIBDIR} \
39                    STAGING_INCDIR=${STAGING_INCDIR} \
40                    BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
41 }
42
43 do_stage() {
44         install -m 0644 Include/*.h ${STAGING_INCDIR}/python2.3/
45 }
46
47 do_install() {
48         install -m 0644 Makefile.orig Makefile
49         oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
50                    HOSTPYTHON=${STAGING_BINDIR}/python \
51                    STAGING_LIBDIR=${STAGING_LIBDIR} \
52                    STAGING_INCDIR=${STAGING_INCDIR} \
53                    BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
54                    DESTDIR=${D} install
55 }
56
57 include python-${PV}-manifest.inc