]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qemu/qemu-native_0.7.0.bb
9e58b5f176b5556a0dded693a86b0017789bd2e1
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qemu / qemu-native_0.7.0.bb
1 include qemu_${PV}.bb
2 inherit native
3 S = "${WORKDIR}/qemu-${PV}"
4 prefix = "${STAGING_DIR}/${BUILD_SYS}"
5
6 python __anonymous() {
7     from bb import which, data
8        
9     path = data.getVar('PATH', d)
10     if len(which(path, 'gcc-3.4')) != 0:
11         data.setVar('EXTRA_OECONF', " --cc=gcc-3.4", d)
12     elif len(which(path, 'gcc-3.3')) != 0:
13         data.setVar('EXTRA_OECONF', " --cc=gcc-3.3", d)
14
15 }