]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qpe-gaim/qpe-gaim_20041030.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qpe-gaim / qpe-gaim_20041030.bb
1 DESCRIPTION = "A multi protocol instant messager application, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
4 DEPENDS = "qpe-libgaim glib-2.0"
5 RDEPENDS = "libgaim-plugins glibc-gconv-iso8859-1"
6 LICENSE = "GPL"
7 HOMEPAGE = "http://qpe-gaim.sourceforge.net/"
8 APPNAME = "gaim"
9 APPTYPE = "binary"
10 LICENSE = "GPL"
11 APPDESKTOP = "${S}"
12 PR = "r2"
13
14 SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
15            file://qpe-gaim.patch;patch=1 \
16            file://buzzer-notification.patch;patch=1;pnum=1 \
17            file://vit.patch;patch=1"
18 S = "${WORKDIR}/qpe-gaim"
19
20 inherit opie
21
22 EXTRA_QMAKEVARS_POST +="INCLUDEPATH-=${includedir}/glib-2.0 \
23                         INCLUDEPATH-=${libdir}/glib-2.0/include \
24                         INCLUDEPATH+=${STAGING_INCDIR}/glib-2.0 \
25                         LIBS-=-lopie LIBS+=-lopiecore2 LIBS+=-lopieui2"
26
27 do_configure_prepend() {
28         ln -s ../libgaim/src libgaim
29 }
30
31 do_install() {
32         for dir in 16x16 32x32 protocols status
33         do
34                 install -d ${D}${palmtopdir}/pics/gaim/${dir}
35                 install -m 0644 data/images/${dir}/*.png ${D}${palmtopdir}/pics/gaim/${dir}/
36         done
37         install -m 0644 gaim.png ${D}${palmtopdir}/pics/
38 }