]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qpe-gaim/qpe-libgaim_1.5.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qpe-gaim / qpe-libgaim_1.5.0.bb
1 DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
4 DEPENDS = "glib-2.0 gnutls"
5 RDEPENDS = "libgaim-plugins"
6 LICENSE = "GPL"
7 HOMEPAGE = "http://gaim.sourceforge.net/"
8 PR = "r3"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/gaim/gaim-${PV}.tar.bz2 \
11            file://dont-look-for-gtk.patch;patch=1        \
12            file://libgaim.patch;patch=1 "
13
14 S = "${WORKDIR}/gaim-${PV}"
15
16 inherit autotools
17
18 EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
19                  --disable-screensaver --disable-sm --disable-glibtest \
20                  --disable-gtktest --disable-startup-notification \
21                  --disable-gevolution --disable-aotest --disable-audiofiletest \
22                  --disable-x --without-x --without-gtk --disable-gtk \
23                  --enable-gnutls=y"
24
25 CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
26
27 do_stage() {
28         oe_libinstall -so -C src libgaim ${QTDIR}/lib
29
30         # install headers
31         GAIM_DIR=${STAGING_INCDIR}/gaim
32         install -d $GAIM_DIR
33
34         for header in account.h accountopt.h away.h blist.h buddyicon.h cmds.h config.h connection.h conversation.h core.h debug.h eventloop.h ft.h gaim.h imgstore.h log.h md5.h network.h notify.h plugin.h pluginpref.h pounce.h prefix.h prefs.h privacy.h proxy.h prpl.h request.h roomlist.h server.h sha.h signals.h sound.h sslconn.h status.h stringref.h util.h value.h version.h xmlnode.h
35         do
36                 if [ -e ${S}/src/$header ]; then
37                         install -m 0644 ${S}/src/$header $GAIM_DIR      
38                 fi
39                 if [ -e ${S}/$header ]; then
40                         install -m 0644 ${S}/$header $GAIM_DIR
41                 fi
42         done
43 }
44
45 #FIXME: use do_packages to create individual packages for each of the plugins
46 python populate_packages_prepend () {
47         plugindir = bb.data.expand('${libdir}/gaim', d)
48         do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
49 }
50
51 PACKAGES += "libgaim-plugins"
52 FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
53