]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qpe-games/crossword_0.0.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qpe-games / crossword_0.0.3.bb
1 DESCRIPTION = "Checkers"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 MAINTAINER = "Team Opie <opie@handhelds.org>"
5 LICENSE = "GPL"
6 AUTHOR = "Robert Ernst"
7 HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Crossword.html"
8
9 SRC_URI = "http://handhelds.org/~zecke/oe_packages/crossword_V0.0.3.tar.gz \
10            file://crossword.patch;patch=1"
11
12 PV = "0.0.3"
13 S = "${WORKDIR}/crossword_V${PV}"
14
15 APPNAME = "crossword"
16 APPTYPE = "binary"
17 APPDESKTOP = "${S}"
18
19 do_install () {
20         install -d ${D}${palmtopdir}/pics/${APPNAME}/
21         install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
22         
23 }
24
25 pkg_postinst() {
26 #!/bin/sh
27
28 MIMEFILE=/opt/QtPalmtop/etc/mime.types
29
30 grep -q application/puz $MIMEFILE 2>/dev/null || echo -e "application/crossword\t\tpuz tpz" >> $MIMEFILE
31 }
32
33 inherit opie