]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qpe-games/sokoban_1.3.8ern.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qpe-games / sokoban_1.3.8ern.bb
1 DESCRIPTION = "Pairs"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 MAINTAINER = "Team Opie <opie@handhelds.org>"
5 LICENSE = "GPL"
6 AUTHOR = "Anders Widell, Steve Dunham, Robert Ernst"
7 HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Sokoban.html"
8
9
10 SRC_URI = "http://handhelds.org/~zecke/oe_packages/sokoban_V1.3.8ern.tar.gz \
11            file://sokoban.patch;patch=1"
12
13 PV = "1.3.8ern"
14 S = "${WORKDIR}/sokoban_V${PV}"
15
16 APPNAME = "sokoban"
17 APPTYPE = "binary"
18 APPDESKTOP = "${S}"
19
20 do_compile_prepend() {
21         oe_runmake -C images    
22         oe_runmake -C levels
23 }
24
25 do_install () {
26         install -d ${D}${palmtopdir}/pics/${APPNAME}/
27         install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
28         
29 }
30
31 inherit opie
32