]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qpe-vexed/qpe-vexed_1.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qpe-vexed / qpe-vexed_1.3.bb
1 DESCRIPTION = "Vexed clone"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
5 LICENSE = "GPL"
6 AUTHOR = "Alexander Hausner <Alexander.Hausner@web.de>"
7 HOMEPAGE = "http://wwwcip.informatik.uni-erlangen.de/~sialhaus/qpe-vexed.html"
8 DEPENDS = "qpe-vexed-levels"
9 RDEPENDS = "qpe-vexed-levels"
10 APPNAME = "qpe-vexed"
11 APPTYPE = "binary"
12 APPDESKTOP = "${S}"
13 PR = "r3"
14
15 SRC_URI = "http://wwwcip.informatik.uni-erlangen.de/~sialhaus/qpe-vexed_1.3_src.tar.gz \
16            file://vit.patch;patch=1"
17
18 S = "${WORKDIR}/qpe-vexed_arm/"
19
20 inherit opie
21
22 do_install () {
23         install -d ${D}${palmtopdir}/pics/${APPNAME}/ \
24                    ${D}${palmtopdir}/apps/Games/ \
25                    ${D}${palmtopdir}/bin/
26
27         install -m 0644 ${S}/pkg/opt/QtPalmtop/pics/qpe-vexed.png ${D}${palmtopdir}/pics/
28         install -m 0644 ${S}/pkg/opt/QtPalmtop/pics/qpe-vexed/*.png ${D}${palmtopdir}/pics/${APPNAME}/
29         install -m 0644 ${S}/pkg/opt/QtPalmtop/pics/qpe-vexed/*.bmp ${D}${palmtopdir}/pics/${APPNAME}/
30 }