]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qplot/qplot_2.0.1+cvs20020420.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qplot / qplot_2.0.1+cvs20020420.bb
1 DESCRIPTION = "QPlot is an Advanced Matematical Calculator for Qt/Embedded based Palmtop Environments"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://qplot.sourceforge.net/"
7 CVSDATE = 20020420
8 PV = "2.0.1-cvs-${CVSDATE}"
9 PR = "r1"
10
11 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/qplot;module=qplot \
12            file://gcc3.patch;patch=1"
13 S = "${WORKDIR}/qplot"
14
15 inherit palmtop
16
17 do_install() {
18         install -d ${D}${palmtopdir}/bin \
19                    ${D}${palmtopdir}/apps/Applications \
20                    ${D}${palmtopdir}/pics \
21                    ${D}${palmtopdir}/lib \
22                    ${D}${palmtopdir}/plugins/inputmethods
23         install -m 755 qplotmain/qplot ${D}${palmtopdir}/bin/qplot
24         install -m 644 qplotmain/qplot.png ${D}${palmtopdir}/pics/
25         install -m 644 qplotmain/qplot-const.b ${D}${palmtopdir}/lib/
26         install -m 644 qplotmain/qplot-math.b ${D}${palmtopdir}/lib/
27         oe_libinstall -so -C qplotmath libqplotmath ${D}${palmtopdir}/plugins/inputmethods/
28         install -m 644 qplot.desktop ${D}${palmtopdir}/apps/Applications/qplot.desktop
29 }