]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qt/qt-x11-free_3.3.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qt / qt-x11-free_3.3.5.bb
1 DESCRIPTION = "Qt/X11 Version ${PV}"
2 SECTION = "x11/libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL QPL"
5 HOMEPAGE = "http://www.trolltech.com"
6 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
7 PR = "r10"
8
9 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2 \
10            file://configure.patch;patch=1 \
11            file://no-examples.patch;patch=1"
12 S = "${WORKDIR}/qt-x11-free-${PV}"
13
14 inherit qmake-base qt3x11
15
16 DEPENDS = "uicmoc3-native freetype x11 xft xext libxrender libxrandr libxcursor mysql"
17 PROVIDES = "qt3x11"
18
19
20 export QTDIR = "${S}"
21 STAGING_QT_DIR = "${STAGING_DIR}/${HOST_SYS}/qt3"
22 ARCH_i686 = "x86"
23 EXTRA_OEMAKE = "-e"
24
25 QT_CONFIG_FLAGS = "-release -shared -qt-zlib -no-nas-sound -no-sm -qt-libpng -no-gif -no-xinerama \
26                    -no-tablet -no-xkb -no-dlopen-opengl -no-nis -no-cups -thread -plugin-sql-mysql -verbose"
27
28 EXTRA_ENV = 'QMAKE="${STAGING_BINDIR}/qmake -after INCPATH+=${STAGING_INCDIR} \
29              INCPATH+=${STAGING_INCDIR}/freetype2 LIBS+=-L${STAGING_LIBDIR}" \
30              QMAKESPEC="${QMAKESPEC}" LINK="${CXX} -Wl,-rpath-link,${STAGING_LIBDIR}" \
31              AR="${TARGET_PREFIX}ar cqs" \
32              MOC="${STAGING_BINDIR}/moc3" UIC="${STAGING_BINDIR}/uic3" MAKE="make -e"'
33
34 do_configure() {
35         echo "yes" | ./configure -prefix ${prefix} ${QT_CONFIG_FLAGS} -fast \
36                 -L${STAGING_LIBDIR} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/freetype2 -I${STAGING_INCDIR}/mysql
37         # force regenerate
38         rm -f src/qtmain.pro
39         cat Makefile >makefile
40         find . -name "Makefile"|xargs rm -f
41         (cd src && qmake -spec ${QMAKESPEC} )
42         (cd plugins/src && qmake -spec ${QMAKESPEC} )
43         (cd tools && qmake -spec ${QMAKESPEC} )
44         (cd tools/qvfb && qmake -spec ${QMAKESPEC} )
45 }
46
47 do_compile() {
48         unset CFLAGS
49         unset CXXFLAGS
50         oe_runmake -C src ${EXTRA_ENV}
51         oe_runmake -C plugins/src ${EXTRA_ENV}
52         oe_runmake -C tools ${EXTRA_ENV}
53         oe_runmake -C tools/qvfb ${EXTRA_ENV}
54 }
55
56 do_stage() {
57         install -d ${STAGING_QT_DIR}/lib
58         oe_soinstall lib/libqt-mt.so.${PV} ${STAGING_QT_DIR}/lib
59         install -d ${STAGING_QT_DIR}/include/private
60         for f in include/*.h
61         do
62                 install -m 0644 $f ${STAGING_QT_DIR}/include/
63         done
64         for f in include/private/*.h
65         do
66                 install -m 0644 $f ${STAGING_QT_DIR}/include/private
67         done
68         for f in lib/*.prl
69         do
70                 install -m 0644 $f ${STAGING_QT_DIR}/lib
71         done
72 }
73
74 do_install() {
75         install -d ${D}${libdir}/
76         oe_soinstall lib/libqt-mt.so.${PV} ${D}${libdir}/
77         install -d ${D}${bindir}/
78         install -m 0755 bin/designer bin/assistant tools/qvfb/qvfb bin/qtconfig ${D}${bindir}
79         install -d ${D}${prefix}/plugins/
80         cp -pPR plugins/imageformats plugins/sqldrivers plugins/designer ${D}${prefix}/plugins/
81 }
82
83 PACKAGES =+ "qt-x11-plugins-imageformats qt-x11-plugins-sqldrivers qt-x11-plugins-designer \
84              qt-x11-designer qt-x11-assistant qt-x11-qvfb qt-x11-qtconfig"
85 FILES_qt-x11-plugins-imageformats = "${prefix}/plugins/imageformats"
86 FILES_qt-x11-plugins-sqldrivers = "${prefix}/plugins/sqldrivers"
87 FILES_qt-x11-plugins-designer = "${prefix}/plugins/designer"
88 FILES_qt-x11-designer = "${bindir}/designer"
89 FILES_qt-x11-assistant = "${bindir}/assistant"
90 FILES_qt-x11-qvfb = "${bindir}/qvfb"
91 FILES_qt-x11-qtconfig = "${bindir}/qtconfig"