]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qte-fonts-common/qte-fonts-common_3.3.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qte-fonts-common / qte-fonts-common_3.3.5.bb
1 DESCRIPTION= "Tools to update the Qt fontdir"
2 MAINTAINER = "M&N Solutions <info@mn-solutions.de>"
3 SECTION = "opie/base"
4 LICENSE = "GPL QPL"
5 PACKAGE_ARCH = "all"
6 PR = "r3"
7
8 SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.bz2"
9 SRC_URI += "file://update-qtfontdir"
10 S = "${WORKDIR}/qt-embedded-free-${PV}"
11
12 do_compile() {
13         :
14 }
15
16 do_install() {
17         mkdir -p ${D}${sbindir}
18         install -m 755 ${WORKDIR}/update-qtfontdir ${D}${sbindir}
19         mkdir -p ${D}${palmtopdir}/lib/fonts
20         cp -pPR lib/fonts/* ${D}${palmtopdir}/lib/fonts
21         # Delete all other font formats, Qt/E would have a dead slow
22         # application start time if it had to use any other font format
23         # as *.qpf ...
24         find ${D}${palmtopdir}/lib/fonts \
25              -name "*.bdf" \
26           -o -name "*.ttf" \
27           -o -name "*.pfa" \
28           -o -name "*.pfb" | xargs rm
29 }
30
31 PACKAGES = "qte-fonts-common"
32 FILES_${PN} = "${sbindir}"
33
34
35 PACKAGES += "qte-font-fixed"
36 PROVIDES += "qte-font-fixed"
37 FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
38 RDEPENDS_qte-font-fixed = "qte-fonts-common"
39 pkg_postinst_qte-font-fixed() {
40 #!/bin/sh
41 if [ -n "$D" ]; then exit 1; fi
42 set -e
43 . /etc/profile
44 ${sbindir}/update-qtfontdir
45 }
46 pkg_postrm_qte-font-fixed() {
47 #!/bin/sh
48 if [ -n "$D" ]; then exit 1; fi
49 set -e
50 . /etc/profile
51 ${sbindir}/update-qtfontdir -f
52 }
53
54 PACKAGES += "qte-font-helvetica-small"
55 PROVIDES += "qte-font-helvetica-small"
56 FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
57         ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
58 RDEPENDS_qte-font-helvetica-small = "qte-fonts-common"
59 pkg_postinst_qte-font-helvetica-small() {
60 #!/bin/sh
61 if [ -n "$D" ]; then exit 1; fi
62 set -e
63 . /etc/profile
64 ${sbindir}/update-qtfontdir
65 }
66 pkg_postrm_qte-font-helvetica-small() {
67 #!/bin/sh
68 if [ -n "$D" ]; then exit 1; fi
69 set -e
70 . /etc/profile
71 ${sbindir}/update-qtfontdir -f
72 }
73
74 PACKAGES += "qte-font-helvetica-large"
75 PROVIDES += "qte-font-helvetica-large"
76 FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
77         ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
78 RDEPENDS_qte-font-helvetica-large = "qte-fonts-common"
79 pkg_postinst_qte-font-helvetica-large() {
80 #!/bin/sh
81 if [ -n "$D" ]; then exit 1; fi
82 set -e
83 . /etc/profile
84 ${sbindir}/update-qtfontdir
85 }
86 pkg_postrm_qte-font-helvetica-large() {
87 #!/bin/sh
88 if [ -n "$D" ]; then exit 1; fi
89 set -e
90 . /etc/profile
91 ${sbindir}/update-qtfontdir -f
92 }
93
94 PACKAGES += "qte-font-smoothtimes"
95 PROVIDES += "qte-font-smoothtimes"
96 FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
97 RDEPENDS_qte-font-smoothtimes = "qte-fonts-common"
98 pkg_postinst_qte-font-smoothtimes() {
99 #!/bin/sh
100 if [ -n "$D" ]; then exit 1; fi
101 set -e
102 . /etc/profile
103 ${sbindir}/update-qtfontdir
104 }
105 pkg_postrm_qte-font-smoothtimes() {
106 #!/bin/sh
107 if [ -n "$D" ]; then exit 1; fi
108 set -e
109 . /etc/profile
110 ${sbindir}/update-qtfontdir -f
111 }
112
113 PACKAGES += "qte-font-smallsmooth"
114 PROVIDES += "qte-font-smallsmooth"
115 FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
116 RDEPENDS_qte-smallsmooth = "qte-fonts-common"
117 pkg_postinst_qte-font-smallsmooth() {
118 #!/bin/sh
119 if [ -n "$D" ]; then exit 1; fi
120 set -e
121 . /etc/profile
122 ${sbindir}/update-qtfontdir
123 }
124 pkg_postrm_qte-font-smallsmooth() {
125 #!/bin/sh
126 if [ -n "$D" ]; then exit 1; fi
127 set -e
128 . /etc/profile
129 ${sbindir}/update-qtfontdir -f
130 }
131
132 PACKAGES += "qte-font-unicode"
133 PROVIDES += "qte-font-unicode"
134 FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
135 RDEPENDS_qte-font-unicode = "qte-fonts-common"
136 pkg_postinst_qte-font-unicode() {
137 #!/bin/sh
138 if [ -n "$D" ]; then exit 1; fi
139 set -e
140 . /etc/profile
141 ${sbindir}/update-qtfontdir
142 }
143 pkg_postrm_qte-font-unicode() {
144 #!/bin/sh
145 if [ -n "$D" ]; then exit 1; fi
146 set -e
147 . /etc/profile
148 ${sbindir}/update-qtfontdir -f
149 }
150
151 PACKAGES += "qte-font-micro"
152 PROVIDES += "qte-font-micro"
153 FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
154 #RDEPENDS_qte-font-micro = "qte-fonts-common"
155 pkg_postinst_qte-font-micro() {
156 #!/bin/sh
157 if [ -n "$D" ]; then exit 1; fi
158 set -e
159 . /etc/profile
160 ${sbindir}/update-qtfontdir
161 }
162 pkg_postrm_qte-font-micro() {
163 #!/bin/sh
164 if [ -n "$D" ]; then exit 1; fi
165 set -e
166 . /etc/profile
167 ${sbindir}/update-qtfontdir -f
168 }
169
170 # Not in the QtE/3 tar file:
171 #PACKAGES += "qte-font-lcd"
172 #PROVIDES += "qte-font-lcd"
173 #RDEPENDS_qte-font-lcd = "qte-fonts-common"
174 #FILES_qte-font-lcd = "${palmtopdir}/lib/fonts/lcd*"
175 #pkg_postinst_qte-font-lcd () {
176 ##!/bin/sh
177 #if [ -n "$D" ]; then exit 1; fi
178 #set -e
179 #. /etc/profile
180 #${sbindir}/update-qtfontdir
181 #}
182 #pkg_postrm_qte-font-lcd() {
183 ##!/bin/sh
184 #if [ -n "$D" ]; then exit 1; fi
185 #set -e
186 #. /etc/profile
187 #${sbindir}/update-qtfontdir -f
188 #}
189
190 # Not in the QtE/3 tar file:
191 #PACKAGES += "qte-font-japanese"
192 #PROVIDES += "qte-font-japanese"
193 #FILES_qte-font-japanese = "${palmtopdir}/lib/fonts/japanese*"
194 #RDEPENDS_qte-font-japanese = "qte-fonts-common"
195 #pkg_postinst_qte-font-japanese() {
196 ##!/bin/sh
197 #if [ -n "$D" ]; then exit 1; fi
198 #set -e
199 #. /etc/profile
200 #${sbindir}/update-qtfontdir
201 #}
202 #pkg_postrm_qte-font-japanese() {
203 ##!/bin/sh
204 #if [ -n "$D" ]; then exit 1; fi
205 #set -e
206 #. /etc/profile
207 #${sbindir}/update-qtfontdir -f
208 #}
209
210 # Not in the QtE/3 tar file:
211 #PACKAGES += "qte-font-courier"
212 #PROVIDES += "qte-font-courier"
213 #FILES_qte-font-courier = "${palmtopdir}/lib/fonts/cour*"
214 #RDEPENDS_qte-font-courier = "qte-fonts-common"
215 #pkg_postinst_qte-font-courier() {
216 ##!/bin/sh
217 #if [ -n "$D" ]; then exit 1; fi
218 #set -e
219 #. /etc/profile
220 #${sbindir}/update-qtfontdir
221 #}
222 #pkg_postrm_qte-font-courier() {
223 ##!/bin/sh
224 #if [ -n "$D" ]; then exit 1; fi
225 #set -e
226 #. /etc/profile
227 #${sbindir}/update-qtfontdir -f
228 #}