]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/quake/quake1_0.0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / quake / quake1_0.0.1.bb
1 DESCRIPTION = "Quake 1"
2 SECTION = "x11/games"
3 PRIORITY = "optional"
4 DEPENDS = "libsdl-x11 libsdl-mixer libsdl-net zlib"
5 MAINTAINER = "Simon Pickering <S.G.Pickering@bath.ac.uk>"
6 LICENSE = "GPL"
7 PR = "r2"
8
9 SRC_URI = "http://mirror1.pdaXrom.org/rc9/src/quake1src.tar.bz2 \
10            http://mirror1.pdaxrom.org/source/src/pak0.tar.gz \
11            file://Makefile.patch;patch=1 \
12            file://cl_parse.c.patch;patch=1 \
13            file://vid_sdl.c.patch;patch=1 \
14            file://host.c.patch;patch=1"
15
16 S = "${WORKDIR}/quake1src"
17
18 inherit autotools 
19
20 EXTRA_OEMAKE = "-e"
21
22 export CFLAG = "-DHAVE_ZLIB -DNO_DEBUG -finline-function"
23 export CXXFLAGS = "-DHAVE_ZLIB -DNO_DEBUG -finline-function"
24 export LIBS = "-L${STAGING_LIBDIR} -lz -lm -lX11 -lXext -lXau `${STAGING_BINDIR}/sdl-config --libs`"
25
26 do_install() {
27         install -d ${D}${bindir}
28         install -m 0755 quake ${D}${bindir}
29 }
30