]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/qwt/qwt_4.2.0rc1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / qwt / qwt_4.2.0rc1.bb
1 DESCRIPTION = "Qt Widget Extension for Technical Applications"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 DEPENDS = "virtual/libqte2"
7 PR = "r1"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tgz \
10           file://qt2-fix.patch;patch=1"
11
12 inherit qmake
13
14 EXTRA_QMAKEVARS_POST = "CONFIG-=thread"
15
16 do_stage() {
17         oe_libinstall -so -C lib libqwt ${STAGING_LIBDIR}
18         cp -pPR include/* ${STAGING_INCDIR}
19 }
20
21 do_install() {
22         install -d ${D}${libdir} \
23                    ${D}${includedir}
24         oe_libinstall -so -C lib libqwt ${D}${libdir}
25         cp -pPR include/* ${D}${includedir}
26 }
27