]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/readline/readline_4.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / readline / readline_4.3.bb
1 DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2 command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes  \
3 additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those   \
4 lines, and perform csh-like history expansion on previous commands."
5 SECTION = "libs"
6 PRIORITY = "optional"
7 MAINTAINER = "Greg Gilbert <greg@treke.net>"
8 LICENSE = "GPLv2"
9 DEPENDS += "ncurses"
10 RPROVIDES_${PN} += "readline"
11 LEAD_SONAME = "libreadline.so"
12 PR = "r2"
13
14 SRC_URI = "ftp://ftp.cwru.edu/pub/bash/readline-${PV}.tar.gz \
15            file://shlink-termcap.patch;patch=1 \
16            file://acinclude.m4"
17 S = "${WORKDIR}/readline-${PV}"
18
19 inherit autotools 
20
21 do_configure () {
22         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
23         autotools_do_configure
24 }
25
26 do_install () {
27         autotools_do_install
28         # Make install doesn't properly install these
29         oe_libinstall -so -C shlib libhistory ${D}${libdir}
30         oe_libinstall -so -C shlib libreadline ${D}${libdir}
31 }
32
33 do_stage() {
34         oe_libinstall -a libhistory ${STAGING_LIBDIR}
35         oe_libinstall -a libreadline ${STAGING_LIBDIR}
36         oe_libinstall -so -C shlib libhistory ${STAGING_LIBDIR}
37         oe_libinstall -so -C shlib libreadline ${STAGING_LIBDIR}
38
39         install -d ${STAGING_INCDIR}/readline
40         for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
41           rlconf.h rltypedefs.h
42         do
43                 install -m 0644 $f ${STAGING_INCDIR}/readline/
44         done
45
46 }