]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/recode/recode_3.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / recode / recode_3.6.bb
1 DESCRIPTION = "Charset converting utility"
2 SECTION = "console/utils"
3 LICENSE = "GPL"
4
5 SRC_URI = "${GNU_MIRROR}/recode/recode-${PV}.tar.gz"
6
7 inherit autotools
8
9 do_configure() {
10         gnu-configize
11         oe_runconf
12         echo "#undef malloc" >>config.h
13         echo "#undef realloc" >>config.h
14 }
15
16 do_stage() {
17         install -m 0644 src/recode.h ${STAGING_INCDIR}/
18         install -m 0644 src/recodext.h ${STAGING_INCDIR}/
19         oe_libinstall -a -C src librecode ${STAGING_LIBDIR}/
20 }
21