]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/rhythmbox/rhythmbox_0.8.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / rhythmbox / rhythmbox_0.8.5.bb
1 LICENSE = "GPL"
2 SECTION = "unknown"
3 PR = "r3"
4 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/rhythmbox/0.8/rhythmbox-${PV}.tar.gz \
5            file://ogg.m4 file://vorbis.m4"
6
7 DEPENDS = "gstreamer gst-plugins libgnomeui"
8
9 EXTRA_OECONF = "--disable-schemas-install"
10
11 FILES_${PN} += " ${libdir}/bonobo/servers ${libdir}/bonobo/*.so ${datadir}/omf ${datadir}/mime-info \
12         ${datadir}/application-registry ${datadir}/gnome-2.0 ${datadir}/idl"
13 FILES_${PN}-doc += " ${datadir}/gnome/help"
14 FILES_${PN}-dev += " ${libdir}/bonobo/*.la ${libdir}/bonobo/*.a"
15
16 RDEPENDS_${PN} = "gst-plugin-gnomevfs gst-plugin-esd gst-plugin-mad gst-plugin-ivorbis"
17
18 do_configure_prepend() {
19         mkdir -p ${S}/m4
20         cp ${WORKDIR}/ogg.m4 ${S}/m4/
21         cp ${WORKDIR}/vorbis.m4 ${S}/m4/
22 }
23
24 inherit autotools gconf
25
26 do_compile() {
27         oe_runmake ORBIT_IDL=`which orbit-idl-2`
28 }