]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/rhythmbox/rhythmbox_0.8.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / rhythmbox / rhythmbox_0.8.7.bb
1 LICENSE = "GPL"
2 SECTION = "unknown"
3 PR = "r0"
4
5 inherit gnome
6
7 SRC_URI += "file://ogg.m4 file://vorbis.m4"
8
9 DEPENDS = "gstreamer gst-plugins libgnomeui"
10
11 EXTRA_OECONF = "--disable-schemas-install"
12
13 FILES_${PN} += " ${libdir}/bonobo/servers ${libdir}/bonobo/*.so ${datadir}/omf ${datadir}/mime-info \
14         ${datadir}/application-registry ${datadir}/gnome-2.0 ${datadir}/idl"
15 FILES_${PN}-doc += " ${datadir}/gnome/help"
16 FILES_${PN}-dev += " ${libdir}/bonobo/*.la ${libdir}/bonobo/*.a"
17
18 RDEPENDS_${PN} = "gst-plugin-gnomevfs gst-plugin-esd gst-plugin-mad gst-plugin-ivorbis"
19
20 do_configure_prepend() {
21         mkdir -p ${S}/m4
22         cp ${WORKDIR}/ogg.m4 ${S}/m4/
23         cp ${WORKDIR}/vorbis.m4 ${S}/m4/
24 }
25
26 do_compile() {
27         oe_runmake ORBIT_IDL=`which orbit-idl-2`
28 }