]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/rpm/rpm_4.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / rpm / rpm_4.4.bb
1 DESCRIPTION = "The RPM Package Manager."
2 HOMEPAGE = "http://rpm.org/"
3 LICENSE = "LGPL GPL"
4 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
5 # NOTE: currently rpm doesn't support using an external popt,
6 # file, or db3.  FIXME: patch it to support that.
7 # DEPENDS = "db3 popt file zlib"
8 DEPENDS = "zlib"
9 PR = "r1"
10
11 SRC_URI = "ftp://ftp.jbj.org/pub/rpm-4.4.x/rpm-4.4-1.src.rpm \
12            file://fix_mypath.patch;patch=1 \
13            file://cross_libpaths.patch;patch=1"
14 TARBALL = "${WORKDIR}/rpm-4.4.tar.gz"
15
16 inherit autotools gettext
17
18 acpaths = ""
19 # NOTE: currently BROKEN because its internal build of 'file' tries
20 # to run the binary it builds.  Either switch to an external build,
21 # or depend on our file-native and make it call that.
22 BROKEN = "1"
23 EXTRA_OECONF = "--without-python \
24                 --without-apidocs \
25                 --without-selinux \
26                 --without-lua \
27                 --without-dmalloc \
28                 --without-efence"
29
30 python unpack_again () {
31         import bb, os
32         os.chdir(bb.data.getVar('WORKDIR', d, 1) or '')
33         if not oe_unpack_file(bb.data.expand('${TARBALL}', d), d):
34                 raise bb.build.FuncFailed(bb.data.expand("Unable to unpack ${TARBALL}", d))
35 }
36
37 python do_unpack () {
38         bb.build.exec_func('base_do_unpack', d)
39         bb.build.exec_func('unpack_again', d)
40 }
41
42 do_configure () {
43         touch db3/configure.ac
44         autotools_do_configure
45 }