]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/rtaudio/librtaudio_3.0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / rtaudio / librtaudio_3.0.1.bb
1 DESCRIPTION = "RtAudio is a set of C++ classes which provide a common API \
2 for realtime audio input/output across Linux (native ALSA, JACK, and OSS), \
3 Macintosh OS X, SGI, and Windows (DirectSound and ASIO) operating systems."
4 SECTION = "libs"
5 LICENSE = "rtaudio"
6 HOMEPAGE = "http://www.music.mcgill.ca/~gary/rtaudio"
7 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
8 DEPENDS = "alsa-lib"
9 PR = "r0"
10
11 SRC_URI = "http://music.mcgill.ca/~gary/rtaudio/release/rtaudio-${PV}.tar.gz"
12 S = "${WORKDIR}/rtaudio-${PV}"
13
14 inherit qmake qt3x11
15
16 do_configure_prepend() {
17         qmake -project -t lib -nopwd *.cpp *.h
18 }
19
20 EXTRA_QMAKEVARS_POST = "CONFIG=console CONFIG+=thread DEFINES+=__LINUX_OSS__ DEFINES+=__LINUX_ALSA__ LIBS+=-lasound"
21
22 do_stage() {
23         install -m 0644 *.h ${STAGING_INCDIR}
24         oe_libinstall -so librtaudio-3.0.1 ${STAGING_LIBDIR}
25 }
26
27 do_install() {
28         oe_libinstall -so librtaudio-3.0.1 ${D}${libdir}
29 }