]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/rtaudio/rtaudio-tests_3.0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / rtaudio / rtaudio-tests_3.0.1.bb
1 include librtaudio_${PV}.bb
2
3 inherit autotools
4
5 EXTRA_OECONF = "--with-alsa --with-oss"
6 EXTRA_OEMAKE = "-e"
7 export CC = "${CXX}"
8 CFLAGS += "-I${S}"
9 export LIBRARY = "-lasound -lpthread ${LDFLAGS}"
10
11 do_compile() {
12         oe_runmake -C tests
13 }
14
15 do_stage() {
16         :
17 }
18
19 do_install() {
20         install -d ${D}${bindir}
21         for binary in `find tests -perm 0755 -type f`
22         do
23                 install -m 0755 $binary ${D}${bindir}
24         done
25 }
26