]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/rxvt-unicode/rxvt-unicode_5.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / rxvt-unicode / rxvt-unicode_5.2.bb
1 SECTION = "x11/utils"
2 DEPENDS = "x11 xt libxft"
3 DESCRIPTION = "rxvt-unicode is a clone of the well known \
4 terminal emulator rxvt, modified to store text in Unicode \
5 (either UCS-2 or UCS-4) and to use locale-correct input and \
6 output. It also supports mixing multiple fonts at the \
7 same time, including Xft fonts."
8 LICENSE = "GPL"
9 SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
10            file://signedchar.patch;patch=1"
11
12 inherit autotools update-alternatives
13
14 PROVIDES = "virtual/x-terminal-emulator"
15 ALTERNATIVE_NAME = "x-terminal-emulator"
16 ALTERNATIVE_PATH = "${bindir}/rxvt"
17
18 CFLAGS_append = " -fpermissive"
19
20 EXTRA_OECONF = "--enable-menubar --enable-xim \
21                 --enable-utmp --enable-wtmp --enable-lastlog \
22                 --disable-strings --with-term=rxvt --enable-keepscrolling \
23                 --enable-xft --with-name=rxvt --enable-frills \
24                 --enable-swapscreen --enable-transparency \
25                 --with-codesets=eu \
26                 --enable-cursor-blink --enable-pointer-blank \
27                 --enable-text-blink --enable-plain-scroll \
28                 --enable-combining --enable-shared \
29                 --enable-xgetdefault \
30                 --with-x=${STAGING_LIBDIR}/.."
31 EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
32                 'XLIB=-L${STAGING_LIBDIR} -lX11'"
33
34 do_configure () {
35         mv autoconf/configure.in . || true
36         rm autoconf/libtool.m4
37         libtoolize --force
38         autotools_do_configure
39         echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
40         echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
41         echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
42         echo '#define HAVE_XLOCALE 1' >> config.h
43 }
44
45 do_compile () {
46         if test -e ${S}/${HOST_SYS}-libtool; then
47                 LIBTOOL=${S}/${HOST_SYS}-libtool
48         else
49                 LIBTOOL=${S}/libtool
50         fi
51         # docs need "yodl" and I have no idea what that is
52         oe_runmake -C src "LIBTOOL=$LIBTOOL"
53 }