]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sablevm/sablevm_1.12.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sablevm / sablevm_1.12.bb
1 DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
2 HOMEPAGE = "http://sablevm.org"
3 LICENSE = "LGPL"
4 PRIORITY = "optional"
5 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
6 SECTION = "interpreters"
7
8 DEPENDS = "libffi libtool popt \
9            sablevm-classpath"
10 #          unzip"
11 RRECOMMENDS = "sablevm-classpath (>= ${PV})"
12
13 SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz \
14            file://no-internal-libs.patch;patch=1"
15
16 inherit autotools update-alternatives
17
18 EXTRA_OECONF = "--enable-real-life-brokenness \
19                 --disable-errors-on-warnings --disable-signals-for-exceptions"
20
21 PROVIDES = "virtual/java"
22 ALTERNATIVE_NAME = "java"
23 ALTERNATIVE_PATH = "${bindir}/java-sablevm"
24 ALTERNATIVE_PRIORITY = "350"
25
26 PACKAGES = "${PN} ${PN}-doc lib${PN} lib${PN}-dev"
27
28 FILES_${PN} = "${bindir} \
29                ${libdir}/${PN}/bin"
30
31 FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
32
33 FILES_lib${PN}-dev = "${includedir}/jni* \
34                       ${libdir}/lib${PN}.so \
35                       ${libdir}/lib${PN}.la"
36
37 do_configure() {
38         # remove internal copies of libpopt and libffi
39         rm -rf src/libpopt src/libffi
40
41         autotools_do_configure
42 }
43
44 do_install() {
45         autotools_do_install
46
47         install -d ${D}${docdir}
48         mv ${D}${datadir}/${PN} ${D}${docdir}/
49
50         # symlink only present in the deb...
51         install -d ${D}${libdir}/${PN}/bin
52         cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
53 }