]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sharp-binary-only / sharp-aticore-oss_1.0.1.bb
1 DESCRIPTION = "Driver for the Ati W100 found on the Sharp Zaurus C[87]x0"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "CLOSED"
5 PR = "r3"
6
7 SRC_URI = "http://mirror1.pdaxrom.org/source/src/AtiCore-1.0.1.tar.bz2 \
8                 file://fixstretchblit.patch;patch=1 \
9                 file://aticore-2.6.patch;patch=1"
10 S = "${WORKDIR}/AtiCore-1.0.1"
11
12 EXTRA_OEMAKE="CC='${CC}' AS='${AS}' AR='${AR}' LD='${LD}' FPU='${TARGET_FPU}'"
13
14 PARALLEL_MAKE = ""
15
16 do_install() {
17         install -d ${D}${bindir}
18         install -m 0755 testcore ${D}${bindir}/testcore
19         install -m 0755 atitest ${D}${bindir}/atitest
20         
21         install -d ${D}${libdir}
22         install -m 0755 libaticore.so.1.0.1 ${D}${libdir}/libaticore.so.1.0.1
23         
24         install -d ${D}${includedir}
25         install -m 0644 aticore.h ${D}${includedir}/aticore.h
26
27         cd ${D}${libdir}/
28         ln -s libaticore.so.1.0.1 libaticore.so.1
29         ln -s libaticore.so.1.0.1 libaticore.so.1.0
30         ln -s libaticore.so.1.0.1 libaticore.so
31 }
32
33 # Currently incompatible with the way sharp-aticore.bb stages.
34 do_stage() {
35         install -m 0644 aticore.h ${STAGING_INCDIR}
36         oe_libinstall -so libaticore ${STAGING_LIBDIR}
37 }
38
39 PACKAGES =+ "sharp-aticore-oss-examples"
40 FILES_sharp-aticore-oss-examples = "${bindir}"
41