]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sharp-binary-only / sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
1 DESCRIPTION = "Driver for the SHARP CG-AG06 digital compact flash camera for linux ${PV}"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "CLOSED"
6 RDEPENDS = "kernel (${KERNEL_VERSION})"
7 PR = "r4"
8
9 SRC_URI = "http://openzaurus.sf.net/mirror/camera-modules-2.4.18-rmk7-pxa3-embedix.tar.bz2 \
10            file://CE-AG06.dat \
11            file://sharpzdc \
12            file://sharpzdc.conf"
13 S = "${WORKDIR}"
14
15 inherit module-base
16
17 do_install() {
18         install -d ${D}${sysconfdir}/pcmcia/cis
19         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia
20         install -m 0644 ${WORKDIR}/CE-AG06.dat ${D}${sysconfdir}/pcmcia/cis/
21         install -m 0644 ${WORKDIR}/sharpzdc.conf ${D}${sysconfdir}/pcmcia/
22         install -m 0755 ${WORKDIR}/sharpzdc ${D}${sysconfdir}/pcmcia/
23         install -m 0644 ${MACHINE}/sharpzdc_cs.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
24 }
25
26 FILES_${PN} = "/"
27
28 PACKAGE_ARCH = "${MACHINE_ARCH}"