]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sharp-binary-only/sharp-compat-libs_0.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sharp-binary-only / sharp-compat-libs_0.5.bb
1 DESCRIPTION = "Allows applications compiled with 2.95 to run on a 3.x compiled \
2 system by providing 2.95 libraries. To run compatible programs, use the Compat \
3 Library program in the Settings menu to make them use these libraries."
4 SECTION = "opie/settings"
5 PRIORITY = "optional"
6 DEPENDS = "opie-sh"
7 RDEPENDS = "opie-sh"
8 RPROVIDES = "oz-compat"
9 RCONFLICTS = "oz-compat"
10 MAINTAINER = "Tim Ansell <mithro AT mithis.net>"
11 LICENSE = "GPL"
12 PR = "r2"
13
14 EXCLUDE_FROM_SHLIBS = "1"
15 COMPATIBLE_HOST = "arm.*-linux"
16
17 SRC_URI = "http://openzaurus.org/mirror/oz-compat_0.5.tar.gz \
18            file://hentges.patch;patch=1 \
19            file://qt2310.patch;patch=1"
20
21 S = "${WORKDIR}/oz-compat-0.5"
22
23 inherit update-rc.d
24
25 INITSCRIPT_NAME = "quickexec"
26 INITSCRIPT_PARAMS = "defaults 10"
27
28 do_install() {
29         install -d ${D}${palmtopdir}/apps/Settings
30         install -d ${D}${palmtopdir}/bin/
31         install -d ${D}${palmtopdir}/etc/
32         install -d ${D}${palmtopdir}/pics/
33         
34         install -d ${D}/opt/QtPalmtop.compat/bin
35         install -d ${D}/opt/QtPalmtop.compat/binlib
36         install -d ${D}/opt/QtPalmtop.compat/lib
37         
38         install -d ${D}${sysconfdir}/init.d
39         
40         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop/apps/Settings/makecompat.desktop ${D}${palmtopdir}/apps/Settings         
41         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop/etc/quickexec.libs ${D}${palmtopdir}/etc/quickexec.libs
42         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop/pics/libraries.png ${D}${palmtopdir}/pics/libraries.png
43         
44         install -m 0755 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop.compat/bin/* ${D}/opt/QtPalmtop.compat/bin
45         install -m 0644 ${WORKDIR}/oz-compat-0.5/opt/QtPalmtop.compat/lib/* ${D}/opt/QtPalmtop.compat/lib
46         
47         install -m 0755 ${WORKDIR}/oz-compat-0.5/etc/init.d/quickexec ${D}${sysconfdir}/init.d
48                         
49         cd ${D}${palmtopdir}/bin
50         for file in chkhinge makecompat qeserver quickexec runcompat
51         do
52                 ln -s /opt/QtPalmtop.compat/bin/$file
53         done
54         
55         cd ${D}/opt/QtPalmtop.compat/lib
56         ln -s libqpe.so.1.5.0 libqpe.so.1.5
57         ln -s libqpe.so.1.5.0 libqpe.so.1
58         ln -s libqpe.so.1.5.0 libqpe.so
59         
60         ln -s libqte.so.2.3.7 libqte.so.2.3.2
61         ln -s libqte.so.2.3.7 libqte.so.2.3     
62         ln -s libqte.so.2.3.7 libqte.so.2
63         ln -s libqte.so.2.3.7 libqte.so
64                 
65         
66 }
67
68 pkg_postinst() {
69 test -n "$D" && exit 1
70
71 # needed for update-rc.d
72 test -e /media/card/etc/init.d/quickexec && ln -s /media/card/etc/init.d/quickexec /etc/init.d/quickexec
73 test -e /media/cf/etc/init.d/quickexec && ln -s /media/cf/etc/init.d/quickexec /etc/init.d/quickexec
74 test -e /media/ram/etc/init.d/quickexec && ln -s /media/ram/etc/init.d/quickexec /etc/init.d/quickexec
75 }
76
77 pkg_postrm() {
78         test -e /etc/init.d/quickexec && rm /etc/init.d/quickexec
79 }
80
81 FILES_${PN} += "/opt /etc"
82 LEAD_SONAME = "libqte.so.*"