]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sharprom-toolchain/sharprom-toolchain-native_1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sharprom-toolchain / sharprom-toolchain-native_1.0.bb
1 DESCRIPTION = "Precompiled SharpROM toolchain glue package"
2 LICENSE = "GPL"
3 SECTION = "base"
4 # This needs to be extracted to /usr/local/arm :
5 # SRC_URI = "http://handhelds.org/download/projects/toolchain/archive/cross-2.95.3.tar.bz2"
6
7 inherit native
8 DEPENDS = ""
9
10 COMPATIBLE_HOST = 'i.86.*-linux'
11
12 do_stage() {
13         if [ ! -e /usr/local/arm/2.95.3/bin/arm-linux-gcc-2.95 ]
14         then
15                 die "You need to install the Sharp Toolchain to /usr/local/arm and rename the compiler to arm-linux-gcc-2.95"
16         fi
17         if [ ! -e /usr/local/arm/2.95.3/bin/arm-linux-ld-2.11.2 ]
18         then
19                 die "You need to install the Sharp Toolchain to /usr/local/arm and rename the linker to arm-linux-ld-2.11.2"
20         fi
21         ln -sf /usr/local/arm/2.95.3/bin/arm-linux-gcc-2.95 ${STAGING_BINDIR}/arm-linux-gcc
22         ln -sf /usr/local/arm/2.95.3/bin/arm-linux-ld-2.11.2 ${STAGING_BINDIR}/arm-linux-ld
23 }
24