]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/shfs/shfs-utils_0.35.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / shfs / shfs-utils_0.35.bb
1 DESCRIPTION = "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
2 It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
3 SECTION = "kernel/userland"
4 PRIORITY = "optional"
5 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
6 LICENSE = "GPL"
7 RDEPENDS = "shfs-modules (${PV})"
8 DEPENDS = "virtual/kernel"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
11 S = "${WORKDIR}/shfs-${PV}/shfsmount"
12
13 KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
14 KV = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')[:3]}"
15
16 CFLAGS_append=' -DVERSION=\\"${KERNEL_VERSION}\\" -DSHFS_VERSION=\\"${PV}\\" -I../shfs/Linux-${KV}'
17
18 do_compile() {
19         oe_runmake LINKER="${CC}"
20 }
21
22 do_install() {
23         install -d ${D}${bindir}
24         install -m 0755 shfsmount shfsumount ${D}${bindir}
25 }