]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/slutils/slutils_0.1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / slutils / slutils_0.1.0.bb
1 DESCRIPTION = "Console utilities for certain hardware aspects of Sharp Linux based Zaurii"
2 DESCRIPTION_slfb = "A command-line utility to turn on/off the FrameBuffer on Linux 2.4-based Zaurii"
3 DESCRIPTION_slbl = "A command-line utility to control the BackLight on Linux 2.4-based Zaurii"
4 DESCRIPTION_sltime = "A ustility to save and restore the time on Sharp Linux based Zaurii"
5 SECTION = "console/utils"
6 PRIORITY = "optional"
7 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
8 LICENSE = "GPL"
9 PR = "r4"
10
11 inherit qmake update-rc.d
12
13 SRC_URI = "file://sltime.sh"
14
15 INITSCRIPT_NAME = "sltime"
16 INITSCRIPT_PARAMS = "defaults 5"
17
18 export UTILS = "sltime slbl slfb"
19
20 do_fetch() {
21         for u in ${UTILS}
22         do
23                 install -d ${S}/$u
24                 cp -dfR `ls -dp ${FILESDIR}/$u/*|grep -v SCCS` ${S}/$u/
25         done
26 }
27
28 do_configure_prepend() {
29         cd ${S}/
30         echo -e "TEMPLATE=subdirs\nSUBDIRS=${UTILS}\n" >slutils.pro
31 }
32
33 do_install() {
34         install -d ${D}${sbindir}
35         for u in ${UTILS}
36         do
37                 install -m 0755 ${S}/${u}/${u} ${D}${sbindir}/
38         done
39         install -d ${D}${sysconfdir}/init.d/
40         install -m 0755 ${WORKDIR}/sltime.sh ${D}${sysconfdir}/init.d/sltime
41 }
42
43 PACKAGES =+ "slbl slfb"
44 FILES_slbl = "${sbindir}/slbl"
45 FILES_slfb = "${sbindir}/slfb"
46