]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/smpeg/smpeg_0.4.4+0.4.5cvs20040311.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / smpeg / smpeg_0.4.4+0.4.5cvs20040311.bb
1 LICENSE = "LGPL"
2 SECTION = "console/multimedia"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 DEPENDS = "virtual/libsdl"
6 PROVIDES = "smpeg"
7 DESCRIPTION = "SMPEG is a general purpose MPEG video/audio \
8 player for Linux based on the mpeg_play and SPLAY \
9 MPEG decoders."
10
11 SRC_URI = "cvs://anonymous:anonymous@cvs.icculus.org/cvs/cvsroot;module=smpeg;date=20040311 \
12            file://m4.patch;patch=1 \
13            file://compile.patch;patch=1"
14 S = "${WORKDIR}/smpeg"
15
16 inherit autotools 
17
18 CFLAGS_append = " -I${STAGING_INCDIR}/SDL"
19 EXTRA_OECONF = "--disable-gtktest --disable-opengl-player --without-x \
20                 --without-gtk --disable-gtk-player \
21                 --with-sdl-prefix=${STAGING_LIBDIR}/.. \
22                 --with-sdl-exec-prefix=${STAGING_BINDIR}/.."
23
24 do_configure_prepend () {
25         touch NEWS AUTHORS ChangeLog
26         rm -f acinclude.m4
27 }
28
29 do_stage() {
30         oe_libinstall libsmpeg-0.4 ${STAGING_LIBDIR}
31         ln -sf libsmpeg-0.4.so ${STAGING_LIBDIR}/libsmpeg.so
32
33         for f in "*.h"
34         do
35                 install -m 0644 ${f} ${STAGING_INCDIR}/SDL
36         done
37
38         cat smpeg-config | sed -e "s,-I/usr/include/SDL,-I${STAGING_INCDIR}/SDL," \
39                          | sed -e "s,-I/usr/include/smpeg, ," \
40                          | sed -e "s,libdirs ,mickey_is_cool ," \
41                          | sed -e "s,-lSDL ,-lSDL-1.2 , "> ${STAGING_BINDIR}/smpeg-config
42         chmod a+rx ${STAGING_BINDIR}/smpeg-config
43 }
44