]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/snes9x/snes9x_1.43-WIP1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / snes9x / snes9x_1.43-WIP1.bb
1 SECTION = "x11/games"
2 PR = "r3"
3 LICENSE = "snes9x"
4 DEPENDS = "libxxf86dga libxxf86vm"
5 DEPENDS_append_i686 = " nasm-native"
6 RDEPENDS_epia = "kernel-module-joydev"
7
8 SRC_URI = "http://www.lysator.liu.se/snes9x/1.43-WIP1/snes9x-1.43-WIP1-src.tar.gz \
9         file://makefile.patch;patch=1;pnum=2 \
10         file://private.patch;patch=1;pnum=0"
11
12 S = "${WORKDIR}/snes9x-1.43-dev-src/snes9x"
13
14 inherit autotools
15
16 export OECFLAGS="${CFLAGS}"
17 export OELDFLAGS="${LDFLAGS}"
18
19 do_configure() {
20         oe_runconf
21 }
22
23 do_install() {
24         install -d ${D}${bindir}
25         install snes9x ${D}${bindir}
26 }