]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/snmp++/snmp++_3.2.10.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / snmp++ / snmp++_3.2.10.bb
1 DESCRIPTION = "A C++ SNMP library that supports SNMPv1, SNMPv2c and SNMPv3"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "libdes libtomcrypt"
5 LICENSE = "snmp++"
6 SRC_URI = "http://www.agentpp.com/snmp++v${PV}.tar.gz"
7 S = "${WORKDIR}/snmp++/src"
8
9 CFLAGS_append = " -I../include"
10
11 do_compile() {
12         oe_runmake -f Makefile.linux LIBDESDIR=${STAGING_LIBDIR} LIBTOMCRYPTDIR=${STAGING_LIBDIR}
13 }
14
15 do_stage() {
16         oe_libinstall -a -C ../lib libsnmp++ ${STAGING_LIBDIR}/
17         install -d ${STAGING_INCDIR}/snmp++
18         install -m 0644 ../include/*.h ${STAGING_INCDIR}/snmp++
19 }