]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sphinx/pocketsphinx_0.2.1.bb
Add sphinxbase and pocketsphinx.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sphinx / pocketsphinx_0.2.1.bb
1 # pocketsphinx OE build file
2 # Copyright (C) 2006, Rene Wagner. All Rights Reserved
3 # Released under the MIT license (see org.handhelds.familiar/COPYING.MIT)
4
5 DESCRIPTION = "Sphinx speech recognition system for handhelds"
6 LICENSE = "BSD"
7 PRIORITY = "optional"
8 SECTION = "sound"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/${PN}-${PV}.tar.bz2"
11
12 inherit autotools
13
14 CFLAGS =+ "-I${STAGING_INCDIR}/sphinxbase"
15 CPPFLAGS =+ "-I${STAGING_INCDIR}/sphinxbase"
16
17 PACKAGES =+ "lib${PN} ${PN}-model-hmm ${PN}-model-lm"
18 FILES_lib${PN} = "${libdir}/*.so.*"
19 FILES_${PN}-model-hmm = "${datadir}/${PN}/model/hmm"
20 FILES_${PN}-model-lm = "${datadir}/${PN}/model/lm"
21 RRECOMMENDS_${PN} = "${PN}-model-hmm ${PN}-model-lm"