]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sphinx/sphinxbase_0.1.bb
592d39c422246bd50e65ae992e60bdff21c1324a
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sphinx / sphinxbase_0.1.bb
1 # sphinxbase OE build file
2 # Copyright (C) 2006, Rene Wagner. All Rights Reserved
3 # Released under the MIT license (see org.handhelds.familiar/COPYING.MIT)
4
5 DESCRIPTION = "Common libraries and utilities of the Sphinx family of speech recognition systems"
6 LICENSE = "BSD"
7 PRIORITY = "optional"
8 SECTION = "libs"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/${PN}-${PV}.tar.bz2"
11
12 inherit autotools
13
14 EXTRA_OECONF_append_arm = " --enable-fixed"
15
16 do_stage() {
17         autotools_stage_all
18 }
19
20 PACKAGES = "${PN}-dev ${PN}-utils"
21 FILES_${PN}-utils = "${bindir}"
22
23 python populate_packages_prepend () {
24         sphinx_libdir = bb.data.expand('${libdir}', d)
25
26         do_split_packages(d, sphinx_libdir, '^libsphinx(.*?)\.so.*$', 'libsphinx%s', bb.data.expand('${DESCRIPTION}', d) + ' - lib%s', aux_files_pattern_verbatim = sphinx_libdir + '/libsphinx%s.*')
27         do_split_packages(d, sphinx_libdir, '^libsphinx(.*?)\.l?a.*$', 'libsphinx%s-dev', bb.data.expand('${DESCRIPTION}', d) + ' - lib%s')
28 }