]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ssmtp/ssmtp_2.60.9.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ssmtp / ssmtp_2.60.9.bb
1 SECTION = "console/network"
2 DEPENDS = "openssl"
3 DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
4 LICENSE = "GPL"
5 SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.tar.gz \
6            file://ldflags.patch;patch=1 \
7            file://configure.patch;patch=1 \
8            file://ssmtp.conf"
9 S = "${WORKDIR}/${PN}-2.60"
10
11 inherit autotools
12
13 EXTRA_OECONF = "--enable-ssl"
14 do_compile () {
15         oe_runmake 'LDFLAGS=${LDFLAGS}'
16 }
17
18 do_install () {
19         oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
20                    'bindir=${D}${bindir}' 'mandir=${D}${mandir}' \
21                    'etcdir=${D}${sysconfdir}' GEN_CONFIG="`which echo`" install
22         install -d ${D}${sysconfdir}/ssmtp
23         install -m 0644 ${WORKDIR}/ssmtp.conf ${D}${sysconfdir}/ssmtp/ssmtp.conf
24 }