]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ssmtp/ssmtp_2.61.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ssmtp / ssmtp_2.61.bb
1 SECTION = "console/network"
2 MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
3 DEPENDS = "openssl"
4 DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
5 LICENCE = "GPL"
6 LICENCE = "GPL"
7 PR = "r5"
8
9 SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.orig.tar.gz \
10            file://ldflags.patch;patch=1 \
11            file://configure.patch;patch=1 \
12            file://libs-lcrypto.patch;patch=1 \
13            file://ssmtp.conf"
14 S = "${WORKDIR}/${PN}-2.61"
15 LICENSE = "GPL"
16 CONFFILES_${PN} = "${sysconfdir}/ssmtp/ssmtp.conf ${sysconfdir}/ssmtp/revaliases"
17 inherit autotools
18
19 EXTRA_OECONF = "--enable-ssl"
20 do_compile () {
21         oe_runmake 'LDFLAGS=${LDFLAGS}'
22 }
23
24 do_install () {
25         oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
26                    'bindir=${D}${bindir}' 'mandir=${D}${mandir}' \
27                    'etcdir=${D}${sysconfdir}' GEN_CONFIG="`which echo`" install
28         install -d ${D}${sysconfdir}/ssmtp
29         install -m 0644 ${WORKDIR}/ssmtp.conf ${D}${sysconfdir}/ssmtp/ssmtp.conf
30 }
31
32 pkg_postinst () {
33         update-alternatives --install ${sbindir}/sendmail sendmail ${bindir}/ssmtp 30
34 }
35
36 pkg_postrm () {
37         update-alternatives --remove ${sbindir}/sendmail sendmail 
38 }