]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/suspend-desktop/suspend-desktop_1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / suspend-desktop / suspend-desktop_1.0.bb
1 PR          = "r0"
2 SECTION     = "gpe"
3 PRIORITY    = "optional"
4 DESCRIPTION = "Suspend feature for the application launcher menu."
5 MAINTAINER  = "Florian Boor <florian@kernelconcepts.de>"
6 LICENSE     = "GPL"
7 DEPENDS     = "gpe-conf"
8 RDEPENDS    = "gpe-conf"
9 RRECOMMENDS = "apm"
10 PACKAGES    = ${PN}
11
12
13 SRC_URI = "file://suspend.desktop \
14            file://suspend.sh"
15
16 FILES_${PN} = "${bindir} ${datadir}"
17
18 do_compile() {
19 }
20
21 do_install() {
22         install -d ${D}/${bindir}
23         install -d ${D}/${datadir}/applications
24         install -m644 ${WORKDIR}/suspend.desktop ${D}/${datadir}/applications/suspend.desktop
25         install -m755 ${WORKDIR}/suspend.sh ${D}/${bindir}/suspend.sh
26 }